lkml.org 
[lkml]   [2004]   [Mar]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    Date
    SubjectRe: 2.6.5-rc3-mm1 - parse_early_options broken
    On Tuesday March 30, akpm@osdl.org wrote:
    >
    > ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.5-rc3/2.6.5-rc3-mm1/
    >
    > - Dropped the tty locking fix. As predicted, it deadlocked. I also
    > reverted the patch from bk-driver-core.patch which is causing this race to
    > trigger more frequently.
    >
    > - Added the rest of Ingo's recent CPU scheduler work. This is for people
    > to compare with 2.6.5-rc2-mm5.

    I tried 2.6.5-rc3-mm1 with a lilo.conf which had:
    append="earlyprintk=vga acpi=off"

    It booted all the way to trying to mount the root filesystem (which is
    on /dev/sda1) and complained something about

    801earlyprintk=vga

    being a bad device name. It looks like the ' ' before earlyprintk has
    been swallowed.
    (lilo would have made a command line of
    auto BOOT_IMAGE=5 ro root=801 earlyprintk=vga acpi=off
    )

    I tried again with
    append="earlyprintk=vga acpi=off root=08:01"
    and it worked fine.

    I hunted around and found parse_early_options and commented out

    if (to != *cmdline_p)
    to -= 1;

    one the basis that it look suspicious, and as "to" is never (as far as
    I can see) going to have the same value as *cmdline_p.

    With this change, it boots nicely with the original append= line.

    (The broken-out patch has a comment, but no "From:" line so I wasn't
    sure who really should be told....)

    NeilBrown

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 14:02    [W:0.021 / U:58.308 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site