[lkml]   [2004]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH] 2.4.x Linux Medley RAID Version 7
    On Wednesday 10 of March 2004 21:11, Thomas Horsten wrote:
    > On Wed, 10 Mar 2004, Bartlomiej Zolnierkiewicz wrote:
    > > Patch for inclusion should have this cleaned up.
    > I have cleaned up the code according to your and Christoph's comments +
    > CodingStyle (and some other cleanups now I was at it).

    Ok, thanks.

    > > The similar thing here - ie. I would like to replug drives to on-board
    > > Intel. When Linux is driving RAID purely in software it shouldn't matter
    > > what controller we are using.
    > I have not changed this. There is simply no reliable way to detect the
    > Medley superblock without comparing these magic words with the PCI values.

    There is still a checksum.

    > My Medley solution for 2.6 will be completely userspace (using dm), and
    > there it will be possible to "force detect" an array with non-matching PCI
    > ID by passing the devices as command line arguments, unfortunately it's
    > not that easy in 2.4 (the whole ataraid is a hack anyway, but a useful one
    > until something better is in place).

    Yep, device-mapper is the way to go.

    > Patch below.

    I will submit it to Marcelo soon...


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:01    [W:0.071 / U:6.568 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site