[lkml]   [2004]   [Dec]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectToshiba PS/2 touchpad on 2.6.X not working along bottom and right sides

    I recently installed Linux 2.6.10 on my Gateway Solo 2500 notebook
    after using it happily with 2.4.27 (aside from some ACPI sleeping
    issues). Since installing the new kernel, I've noticed an odd problem
    with the Toshiba PS/2 touchpad which is used as a cursor. If I move my
    finger left and right along the 'bottom' portion of the touchpad or up
    and down along the right side, there is no movement from the mouse
    cursor at all. This behavior shows up using gdm and XFree86. Running
    'xev' produces no output when these sides are used. However, if I move
    my finger left-right along the top side or up-down along the left
    side, the cursor moves just fine. Tapping the pad to click in the
    non-working areas and moving the finger from outside of these areas
    and then into them, however, works fine.

    It's almost as if the portion of the pad that is sensitive to movement
    has been shifted up and to the left (except that clicking in and
    dragging into this area works).

    I think this might have something to do with the drag-lock function
    because if I move the cursor from, say, the center of the pad and down
    to the lower side, the cursor will begin to move downward when my
    finger gets into the portion of the pad that does not function 100%.
    (This is really only a wild-ass guess, though.)

    I've tried killing gdm and loading up my old 2.4 kernels to be sure
    it's not something else. I've also tried kernels 2.6.5.and 2.6.0 and a
    clean 2.6.10 tree (without the acpi and swsusp2 patches that I want)
    to be sure that this isn't likely to be something that just cropped up
    recently. The old (good, working) behavior is found in a 2.4 kernel
    and some new (bad, faulty) behavior is found in the 2.6 kernels that
    I've tried. I've also tried booting with acpi=off to no avail.

    I realize this problem may seem odd, but I've described it as best I
    can. I also realize that other people are having issues with pointing
    devices and keyboards, so this could just be a related problem that
    will be fixed when those others are fixed as well.

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:09    [W:0.020 / U:112.072 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site