[lkml]   [2004]   [Dec]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: usb-storage loads scsi_mod, but not sd_mod (2.6.9)
Am Sonntag, 26. Dezember 2004 20:19 schrieb William Park:
> Dear USB developers,
> In 2.6.9, 'usb-storage' module depends on 'scsi_mod', but not 'sd_mod'.
> This means that I have to load 'sd_mod' manually, or put something like
> alias block-major-8-* sd_mod
> in /etc/modprobe.conf.
> Is there reason why 'sd_mod' is not listed as one of dependant modules
> for 'usb-storage'?

Yes. You might connect optical and tape drives as well as even other SCSI
devices by bridges. We must not assume all storage devices to use sd.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:09    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean