lkml.org 
[lkml]   [2004]   [Dec]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.10-rc3-mm1-V0.7.33-03 and NVidia wierdness, with workaround...
On Sun, 19 Dec 2004 11:20:03 -0500, Steven Rostedt <rostedt@goodmis.org> wrote:
> On Fri, 2004-12-17 at 17:42 -0500, Valdis.Kletnieks@vt.edu wrote:
>
> > Most likely, the fact you have SMP/HT and I'm just on a PREEMPT-UP kernel is
> > what's making the difference. There's almost certainly a '#ifdef CONFIG_SMP'
> > involved here somehow....
>
> Yep! I just compiled my system without SMP and I was able to start up X
> with NVidia on my HT laptop (with V0.7.33-04).
>
> Ingo, do you think this is a bug with NVidia (bad proprietary module) or
> might be with something in the RT SMP side? I'll look a little more on
> Monday, but if you know of something, let me know. I'm curious to why
> it works fine without RT but will not work with RT (and SMP). I
> shouldn't say NVidia bug, since it only is a problem with the RT SMP, so
> I should say incompatibility w.r.t. RT SMP and NVidia.
>
> If you are one of those that don't want anything to do with the NVidia
> driver, and don't care less if it works or not, let me know that too.
> That way I won't bother you with this anymore and will only communicate
> with Valdis :-)
>
> Thanks,
>
> -- Steve

Nope, I've experianced the same problem without SMP. It also appears
to be a bug where if make menuconfig is not run after using an old
kernel, for some odd reason CONFIG_SPINLOCK_BKL is set to be on.
Anyways, I just wanted to reassure you, this is NOT an SMP bug.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:08    [from the cache]
©2003-2011 Jasper Spaans