Messages in this thread |  | | From | David Brownell <> | | Subject | Re: [linux-usb-devel] [RFC PATCH] debugfs - yet another in-kernel file system | | Date | Fri, 10 Dec 2004 17:29:01 -0800 |
| |
On Thursday 09 December 2004 4:50 pm, Greg KH wrote: > What if there was a in-kernel filesystem that was explicitly just for > putting debugging stuff? Some place other than proc and sysfs, and that > was easier than both of them to use. Yet it needed to also be able to > handle complex stuff like seq file and raw file_ops if needed.
The problem with sysfs here is: no seq_file support. Otherwise it solves the basic "where to put the debug files associated with "device X" or "driver Y" problems in a good non-confusing way: there are directories already set up for devices and for drivers.
The problem with procfs here is that it doesn't have such a naming solution: there's no automatic mapping betwen a /proc/driver/...file and its device, or vice versa. That issue is shared with debugfs.
Couldn't debugfs just be a thin shim on top of sysfs, adding seq_file support? Or on top of procfs, adding device/driver naming domains, and maybe file-per-value read/write support for drivers that want them?
What I'd really want out of a debug file API is to resolve the naming issues, work with seq_file, and "softly and silently vanish away". I think this patch has the last two, but not the first one!
- Dave - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
|  |