lkml.org 
[lkml]   [2004]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] fix platform_rename_gsi related ia32 build breakage


On Thu, 11 Nov 2004, Len Brown wrote:
>
> I used a function pointer here because the same kernel binary must be
> able to run on an ES7000 or a non-ES7000, so the compile-time inline
> idiom doesn't work.

Sure it does. Do something like this in a header file

static inline int translate_irq_number(...)
{
#ifdef CONFIG_ACPI_BOOT
return fn_ptr_xxx();
#else
return irq;
#endif
}

which means that yes, it uses the function pointer when it is meaningful,
but if there is no point, the code just goes away.

> If you read this far and have suggestions for a more descriptive name
> than platform_rename_gsi(), just let me know.

At _least_ write out what the hell "gsi" is.

TLA's are bad. "gsi" apparently isn't the Geological Survey of Ireland,
but that's all I can tell from google.

Linus
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2009-11-18 23:46    [W:0.075 / U:0.152 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site