lkml.org 
[lkml]   [2004]   [Oct]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject2.6.9-mm1: NForce3 problem (IRQ sharing issue?)
Date
Hi,

I have a problem with 2.6.9-mm1 on an AMD64 NForce3-based box. Namely, after
some time in X, USB suddenly stops working and sound goes off simultaneously
(it's quite annoying, as I use a USB mouse ;-)). It is 100% reproducible and
it may be related to the sharing of IRQ 5:

rafael@albercik:~> cat /proc/interrupts
CPU0
0: 3499292 XT-PIC timer
1: 7135 XT-PIC i8042
2: 0 XT-PIC cascade
5: 6945 XT-PIC NVidia nForce3, ohci_hcd
8: 0 XT-PIC rtc
9: 1416 XT-PIC acpi, yenta
10: 2 XT-PIC ehci_hcd
11: 37266 XT-PIC SysKonnect SK-98xx, yenta, ohci1394, ohci_hcd
12: 13781 XT-PIC i8042
14: 16 XT-PIC ide0
15: 23601 XT-PIC ide1
NMI: 0
LOC: 3498657
ERR: 1
MIS: 0

(NVidia nForce3 is a sound chip, snd_intel8x0). After it happens I can't
reboot the box cleanly (the ohci-hcd driver cannot be reloaded) and it does
not leave any traces in the log.

Please let me know if you need any more information.

Greets,
RJW

--
- Would you tell me, please, which way I ought to go from here?
- That depends a good deal on where you want to get to.
-- Lewis Carroll "Alice's Adventures in Wonderland"
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:07    [W:0.146 / U:1.444 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site