[lkml]   [2004]   [Jan]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: PPC & 2.6.0-test3: wrong mem size & hang on ifconfig
> > >  			if (getprop(dev_handle, "reg", mem_info,
> > > - sizeof(mem_info) != 8))
> > > + sizeof(mem_info) != 8)) {

> if ((n = getprop(dev_handle, "reg", mem_info, sizeof(mem_info))
> != 8) {

I tried it (applied it by hand and fixed parens) and it did not print n
and found the right RAM size with todays BK (2.4.24-pre3 by Makefile). I
was confused but did read the patch 3 times. Now I see it - one closing
parenthesis was in the wrong place. Seems you have fixed it in 2.4 tree
already since it's ok in BK.

So 2.4 is OK again on my Motorola Powerstack II Pro4000 (prep, no
residual, OF present). Thanks! dmesg now tells
Memory BAT mapping: BAT2=64Mb, BAT3=0Mb, residual: 0Mb
Total memory = 64MB; using 128kB for hash table (at c0240000)

2.6 probably needs the same fix (current 2.6 is not OK).

Additionally, 2.6 still has the problem with hard hang (no sysrq) when I
do ifconfig eth0 up (21140 driven by tulip or de4x5). I have heard other
people have the same problem - 21140 and 3com on powerstack and some
NIC with tulip driver on another arch (alpha?).

Meelis Roos (

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:59    [W:0.084 / U:0.040 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site