lkml.org 
[lkml]   [2004]   [Jan]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: [patch] Re: Kernels > 2.6.1-mm3 do not boot. - REALLY SOLVED
    Date
    Alle Tuesday 27 January 2004 19:15, Andi Kleen ha scritto:

    > Ok, found it. This patch should fix it. The top level asm in process.c
    > assumed that the section was .text, but that is not guaranteed in a
    > funit-at-a-time compiler. It ended up in the setup section and messed up
    > the argument parsing. This bug could have hit with any compiler,
    > it was just plain luck that it worked with newer gcc 3.3 and 3.4.

    Confirmed here. 2.6.2-rc1-mm3 boots just fine with this patch; without patch
    it hangs just as described before.
    (-funit-at-a-time enabled, of course).

    Many thanks to all.

    --
    Fabio Coatti http://www.ferrara.linux.it/members/cova
    Ferrara Linux Users Group http://ferrara.linux.it
    GnuPG fp:9765 A5B6 6843 17BC A646 BE8C FA56 373A 5374 C703
    Old SysOps never die... they simply forget their password.
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 14:00    [W:0.021 / U:60.348 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site