[lkml]   [2003]   [Sep]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC][PATCH] kmalloc + memset(foo, 0, bar) = kmalloc0 wrote:
> Bad choice of name - too easy to confuse with kmalloc().

kmalloc_and_zero() would be much clearer.

It opens the way for a pool of pre-zeroed pages, too. We know that
improves preformance on some architectures.

-- Jamie
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:48    [W:0.064 / U:0.692 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site