lkml.org 
[lkml]   [2003]   [Aug]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[2.6-test3] bttv driver doesn't run
Date
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi.

I'm running 2.6.0-test3 and the bttv-driver doesn't work
for my Hauppauge WinTV PCI with bt878 chip.

On booting, it throws the following messages:

Aug 9 20:47:06 lfs kernel: bttv: driver version 0.9.11 loaded
Aug 9 20:47:06 lfs kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Aug 9 20:47:06 lfs kernel: bttv: Host bridge is 0000:00:00.0
Aug 9 20:47:06 lfs kernel: bttv: Bt8xx card found (0).
Aug 9 20:47:06 lfs kernel: bttv0: Bt878 (rev 17) at 0000:03:02.0, irq: 18, latency: 32, mmio: 0xddafe000
Aug 9 20:47:06 lfs kernel: bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
Aug 9 20:47:06 lfs kernel: bttv0: using: BT878(Hauppauge (bt878)) [card=10,autodetected]
Aug 9 20:47:06 lfs kernel: bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
Aug 9 20:47:06 lfs kernel: bttv0: Hauppauge eeprom: model=44354, tuner=Philips FM1216 (5), radio=yes
Aug 9 20:47:06 lfs kernel: bttv0: using tuner=5
Aug 9 20:47:06 lfs kernel: bttv0: i2c: checking for MSP34xx @ 0x80... found
Aug 9 20:47:06 lfs kernel: bttv0: i2c: checking for TDA9875 @ 0xb0... not found
Aug 9 20:47:06 lfs kernel: bttv0: i2c: checking for TDA7432 @ 0x8a... not found
Aug 9 20:47:06 lfs kernel: videodev: "BT878(Hauppauge (bt878))" has no release callback. Please fix your driver for proper sysfs support, see http://lwn.net/Articles/36850/
Aug 9 20:47:06 lfs kernel: bttv0: registered device video0
Aug 9 20:47:06 lfs kernel: videodev: "bt848/878 vbi" has no release callback. Please fix your driver for proper sysfs support, see http://lwn.net/Articles/36850/
Aug 9 20:47:06 lfs kernel: bttv0: registered device vbi0
Aug 9 20:47:06 lfs kernel: videodev: "bt848/878 radio" has no release callback. Please fix your driver for proper sysfs support, see http://lwn.net/Articles/36850/
Aug 9 20:47:06 lfs kernel: bttv0: registered device radio0
Aug 9 20:47:06 lfs kernel: bttv0: PLL: 28636363 => 35468950 .. ok


When trying to run the tv-application "tvtime", the kernel
throws some more messages. tvtime worked fine for a few
seconds (video and audio worked), but then it froze and
was non-workable from then on.

Aug 9 20:49:08 lfs kernel: bttv0: skipped frame. no signal? high irq latency?
Aug 9 20:49:08 lfs last message repeated 20 times
Aug 9 20:49:08 lfs kernel: bttv0: IRQ lockup, cleared int mask
Aug 9 20:49:08 lfs kernel: rtc: lost some interrupts at 1024Hz.
Aug 9 20:49:08 lfs kernel: bttv0: timeout: risc=0f7ae874, bits: VSYNC HSYNC OFLOW RISCI
Aug 9 20:49:08 lfs kernel: bttv0: reset, reinitialize
Aug 9 20:49:08 lfs kernel: bttv0: PLL: 28636363 => 35468950 .. ok


Complete syslog after booting this kernel is attached,
because it contains some more error-messages.
I bzip2'ed it because of the size.

I should additionaly say, that the driver worked for
2.6.0-test2, but threw error-messages (I posted this
to lkml before).

- --
Regards Michael Buesch [ http://www.8ung.at/tuxsoft ]
Animals on this machine: some GNUs and Penguin 2.6.0-test3

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQE/NUXNoxoigfggmSgRAjdjAJ0Q/B5QNRuIJo26ZZDTvJ5Pp4YGZwCghDeU
6yj05dEUei5k/9HYI1mgqOA=
=gUfK
-----END PGP SIGNATURE-----
[unhandled content-type:application/x-bzip2]
\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.265 / U:1.164 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site