lkml.org 
[lkml]   [2003]   [Aug]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6 bug: kconfig implementation doesn't match the spec
On Fri, Aug 08, 2003 at 08:01:20PM +0200, Roman Zippel wrote:

> Hi,

Hi Roman,

> On Fri, 8 Aug 2003, Adrian Bunk wrote:
>
> > > You probably forgot to set MODULES, tristate behaves like bool in this
> > > case and FOO becomes 'y' and '!FOO' is 'n'.
> >
> > No, this is with CONFIG_MODULES=y.
>
> How did you set it? I tried your examples and got the expected and correct
> result.

ups, sorry, you are right. I switched between two trees and these
examples were with CONFIG_MODULES=n. With CONFIG_MODULES=y I observe the
correct results.

> > According to your language definition,
> > m && !m
> > evaluates to "m" (it sounds a bit strange but follows directly from
> > rules (5) and (7) together with the interpretation of "m" as 1 as
> > explained in the section "Menu dependencies" of
> > Documentation/kbuild/kconfig-language.txt).
>
> BTW the reason for (5) !<expr> -> 2-<expr> is that it becomes possible to
> do various transformations with the expressions, e.g. !!<expr> == <expr>.

OTOH, the expression
FOO && !FOO
is not always "n" as you might expect.

> bye, Roman

cu
Adrian

--

"Is there not promise of rain?" Ling Tan asked suddenly out
of the darkness. There had been need of rain for many days.
"Only a promise," Lao Er said.
Pearl S. Buck - Dragon Seed

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.034 / U:1.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site