lkml.org 
[lkml]   [2003]   [Aug]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [APM] CPU idle calls causing problem with ASUS P4PE MoBo
From
Date
On Thu, 2003-08-07 at 18:08, Kathy Frazier wrote:
> I am experiencing problems with the CPU idle call feature on an ASUS P4PE
> (Intel 82845PE MCH and Intel 82801DB ICH4 chipsets). I am using kernel
> 2.4.20-8 (Red Hat 9.0).

that's an old kernel.. several updates have followed since... several
machines have been added to the apm idle blacklist in later kernels
>
> We were having trouble with our system "hanging"
> after running for a while. By this I mean, that no IRQs are getting
> through, but software components are still running. We have a proprietary
> PCI DMA bus master device that works fine in PIII system, but the plans are
> to ship our product using this ASUS MoBo. In the process of trying to debug
> this problem, we have updated BIOS, tweaked BIOS parameters, added debug to
> the kernel to determine the status of our IRQ, etc. When I changed the
> CONFIG_APM_CPU_IDLE to no, our 3 hour test runs to completion. Previously
> this test would cause the system to hang within minutes. I have tried
> various combinations of APM tweaking with the following results:

if you can mail the top part of the dmidecode output (the part that has
the bios idents) the machine can trivially be added to the apm idle
blacklist.

[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.242 / U:1.096 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site