lkml.org 
[lkml]   [2003]   [Aug]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: SATA HD 137GB limitation?
Jeff Garzik wrote:
> I just realized, 2.4 kernels don't support scsi's READ_CAPACITY_16, nor
> 64-bit sector_t on a 32-bit processor.
>
> Can you test Alan Cox's 2.6.0-test-ac tree? I bet the 137GB limitation
> may disappear there.

thanks,

just tried 2.6.0-test1-ac3 but it fails, is there a particular
version that might work?

will the READ_CAPACITY_16 and 64-bit sector_t be ported to 2.4 tree?
or do I have to wait for usable 2.6?

2.6.0-test1-ac3 complies OK but when installing modules there are
number of unresolved symbols:

INSTALL lib/zlib_deflate/zlib_deflate.ko
INSTALL lib/zlib_inflate/zlib_inflate.ko
if [ -r System.map ]; then /sbin/depmod -ae -F System.map
2.6.0-test1-ac3; fi
depmod: *** Unresolved symbols in
/lib/modules/2.6.0-test1-ac3/kernel/crypto/def
late.ko
depmod: zlib_inflateInit2_
...
depmod: zlib_deflateReset
depmod: *** Unresolved symbols in
/lib/modules/2.6.0-test1-ac3/kernel/drivers/bl
ock/paride/paride.ko
depmod: parport_unregister_device
..depmod: parport_find_base
depmod: *** Unresolved symbols in
/lib/modules/2.6.0-test1-ac3/kernel/drivers/ch
ar/agp/nvidia-agp.ko
depmod: agp_remove_bridge
...
depmod: agp_generic_alloc_by_type
depmod: *** Unresolved symbols in
/lib/modules/2.6.0-test1-ac3/kernel/drivers/ch
ar/lp.ko
depmod: parport_read
...
depmod: parport_release
depmod: *** Unresolved symbols in
/lib/modules/2.6.0-test1-ac3/kernel/drivers/ch
ar/ppdev.ko
depmod: parport_read
...

I tried to boot the kernel anyway and it fails to boot, right after
LILO line and checking BIOS line it stars to print something so fast
that I have no idea what it is, no keys work, only hw reset... found
nothing relevant on lkml archives... any ideas why it fails (or which
version would be more likely to work)?

TIA

erik

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.054 / U:2.324 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site