lkml.org 
[lkml]   [2003]   [Aug]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: usbcore module can't unload after swsusp
On Wed, Aug 06, 2003 at 10:42:06PM +0300, Micha Feigin wrote:
> I am running a patched kernel 2.4.21 with acpi and swsusp ver 1.0.3
> with usb compiled in as a module.
>
> When kernel loads for the first time everything works fine, all usb
> modules can be loaded and unloaded properly. After suspending and
> restarting, the computer comes up fine and everything works. The
> problem is that at this point, when I try to unload the usbcore module
> it gets to the point of calling usb_hub_cleanup in drivers/usb/hub.c.
> At this points it tried to kill khubd with killproc, which works fine
> (the process is stoped), with a return value of 0. The problem is that
> at this point the function locks on the call
> wait_for_completion(&khubd_exited); which never returns, and rmmod gets
> locked. I tried changing the DECLARE_COMPLETION call so that it will be
> redone each time the module starts but it didn't solve the problem. Any
> ideas on how to further persue this or whether there is a known
> solution?

Unload the usb modules before suspending.

Good luck,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.233 / U:0.584 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site