lkml.org 
[lkml]   [2003]   [Aug]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Hang after "Freeing unused kernel memory" with 2.6 test2
Date
> It's been a while since I tried to compile a kernel, but I did a good 
> effort searching for already existing answers to my situation, so I feel
> I'm in a somewhat unique situation.
>
> As the title says, booting up the kernel hangs after
> Mounted devfs on /dev
> Freeing unused kernel memory: 144k freed
>
> Magic sysreq gives me (painfully transcribed):
>
> SysRq : Show Regs
>
> Pid: 1, comm: init
> EIP: 0060:[<c012634a>] CPU:0
> EIP is at force_sig_info+0x4a/0x100
> EFLAGS: 00000282 Not tainted
> EAX: 00000000 EBX: c14cd840 ECX: 00000002 EDX: 00000000
> ESI: 00000004 EDI: c010c6e0 EBP: c14cff18 DS: 007b ES: 007b
> CR0: 8005003b CR2: 4006e950 CR3: 1dd8d000 CR4: 00000080
> Call Trace:
> [<c010c6e0>] do_invalid_op+0x0/0xb0
> [<c010c747>] do_invalid_op+0x67/0xb0
> [<c012517e>] do_timer+0xfe/0x110
> [<c012517e>] do_timer+0xfe/0x110
> [<c0111236>] timer_interrupt+0xe6/0xf0
> [<c0121563>] do_softirq+0xb3/0xc0
> [<c010c6e0>] do_invalid_op+0x0/0xb0
> [<c010bdcd>] error_code+0x2d/0x40
>
> CTRL-ALT-DEL works, so the system isn't totally hung. But no other
> evidence of activity.

Probably a SIGILL shower is raining on you. Your /sbin/init
is causing it. I had one when I tried to run 686 one on
a 486 box ;)
--
vda
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.050 / U:1.632 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site