lkml.org 
[lkml]   [2003]   [Aug]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectUSB Disk (Archos Jukebox) and 2.6.0-test2 (-mm3)


Since 2.6.0 and on I've had problems with mounting up my Archos Jukebox
MP3 player. In the 2.4.20 kernel I used to:

Power on the unit
plug in the USB cable
modprobe usb-storage
(scsi disk is compiled in)
mount /dev/sda1


Debian Unstable
{1}:/home/nomad>lspci -v | grep -i usb
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 05) (prog-if 00 [UHCI])
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 05) (prog-if 00 [UHCI])

"hotplug" autoloads the module for my visor and it is working properly.
When I plug in archos it sees a device but says there's no module for
the device.

Now when I modprobe usb-storage it hangs the shell and pretty much the
machine. No real output, it just sits there. I've had this same
behavior in 2.6.0-test1, test2 and test2-mm3.

If someone wishes to give me some debug commands to run or alternate
compile options feel free.

Robert


:wq!
---------------------------------------------------------------------------
Robert L. Harris | GPG Key ID: E344DA3B
@ x-hkp://pgp.mit.edu
DISCLAIMER:
These are MY OPINIONS ALONE. I speak for no-one else.

Life is not a destination, it's a journey.
Microsoft produces 15 car pileups on the highway.
Don't stop traffic to stand and gawk at the tragedy.
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.028 / U:0.500 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site