lkml.org 
[lkml]   [2003]   [Aug]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectHelp with debugging of a framebuffer driver on a legacyfree system.
Hi there 

As part of a project I am trying to write a framebuffer device
driver for a graphic chip. Up until now I have compiled my
code as a module and been doing insmod, rmmod and that have worked
nicely.

I then tried to compile the driver into the kernel but that
makes the kernel hang. As my development system are a legacy
free laptop and my driver initializes the screen, the kernel
hangs without me being able to figure out where and why that
happend.

So I seek advice on how to debug the driver! As said, the
laptop are legacy free, so I have not got a serial port.
I have tried a usb->serial adapter, but that requires a driver.
Can I do USB->USB on another computer? Or?

Or am I stuck with coding my own printk variant and writing to the
screen or is there any other option I have not thought of?

Regards Thomas, Denmark
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:48    [W:0.041 / U:8.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site