[lkml]   [2003]   [Aug]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH]O18.1int
On Sat, 23 Aug 2003 19:18, Nick Piggin wrote:
> Hi
> I don't know what is preferred on lkml, but I dislike mixing booleans
> and integer arithmetic.
> if (!LOW_CREDIT(prev))
> prev->interactive_credit--;
> Easier to read IMO.

I agree. I only mixed them because of my (perhaps false) belief that it's less
of a hit not having another if.. branch point. Then again today's compilers
probably optimise it out anyway.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:48    [W:0.077 / U:1.380 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site