lkml.org 
[lkml]   [2003]   [Aug]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [ACPI] Invalid PBLK length for athlon XP-M on Asus laptop
On Sat, Aug 23, 2003 at 06:34:23PM +0100, Matthew Wilcox wrote:
> > [.....]
> > ACPI: Fan [FAN0] (on)
> > acpi_processor-1626 [30] acpi_processor_get_inf: Invalid PBLK length [5]
>
> This is a bug in your ACPI bios, you need a vendor update. We tried
> fixing this but it broke a number of laptops, so we had to revert it.

I already have the latest bios according to Asus site.
I sent a complain to Asus support, we'll see...

Those fixes can still be found somewhere ? I'd like to play with them.

> > NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
> > acpi_processor_perf-0104 [28] acpi_processor_get_per: Unsupported address space [127] (control_register)
> > cpufreq: No CPUs supporting ACPI performance management found.
>
> That means that you need a non-acpi driver for perf throttling. Did you
> try enabling some of the other cpufreq drivers?

I tried with the P-state driver compiled in with the Athlon driver, or
only with the Athlon driver without P-state. The result is the same,
when I try to set a governor through sysfs the system freezes and a
hard reset is required.
However without P-state driver the above message disappers.

So I'm getting neither scaling or throttling... it's not much a surprise
that the battery was discharging at that rate...

--
----------------------------------------
Daniele Venzano
Web: http://digilander.iol.it/webvenza/

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:48    [W:0.052 / U:2.324 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site