lkml.org 
[lkml]   [2003]   [Aug]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.6.0-t3: vfs/ext3 do_lookup bug?!
Date
Andrew Morton wrote:

> Martin Zwickel <martin.zwickel@technotrend.de> wrote:
>>
>> Today I wanted to check out some src-files from cvs.
>> But my fault was, that I ran cvs twice at the same time.
>>
>> so two "cvs upd -d -A" are now in 'D' state.
>>
>> I think they got stuck because both tried to access the same file.
>
> How odd. Were they the only processes which were in D state?

They are probably hung on the same semaphore, ie "dir->i_sem". They almost
certainly are not deadlocked on each other: something else has either left
the directory semaphore locked, or is in turn waiting for something else.

Martin - do you have the _full_ list of processes available?

Linus
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2009-11-18 23:46    [W:0.061 / U:46.644 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site