lkml.org 
[lkml]   [2003]   [Aug]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: APM and 2.5.75 not resuming properly
Stephen Rothwell wrote:
> On Sat, 16 Aug 2003 15:29:33 +0100 Jamie Lokier <jamie@shareable.org> wrote:
> > Rob Landley wrote:
> > > (APM suspends, and then never comes back until you yank the #*%(&#
> > > battery. Great. Trying it with the real mode bios calls next
> > > reboot...)
> >
> > Similar here. Using 2.5.75. APM with no local APIC (kernel is unable
> > to enable it anyway).
> >
> > It suspends. On resume, the screen is blank and the keyboard doesn't
> > respond (no Caps Lock or SysRq). Occasionally when it resumes the
> > keyboard does respond, but the screen stays blank. At least it is
> > possible to do SysRq-S SysRq-B in this state. Sometimes, if I'm
> > lucky, I can make it reboot by holding down the power key for 5 seconds.
>
> I may have missed somthing, but let me ask anyway: What laptop? Have you
> tried switching to a text console before suspending? Have you tried
> Options "NoPM" "True"
> in the ServerFlags section of your XF86Config?

Toshiba Satellite 4070CDT. APM has worked without any problems, in
2.4 and earlier kernels, both Red Hat kernels and vanilla ones.

I'm not using X :)

I am using vesafb, as my text console. Same with 2.4.

I've just noticed a notable change: the Toshiba SMM driver. That is
now configured in, whereas before it was a module and I never loaded
it. Although I don't use it, when it initialises it does some funky
SMM stuff - might that be breaking resume?

-- Jamie
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.048 / U:17.888 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site