[lkml]   [2003]   [Aug]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRE: Update MSI Patches
On Fri, 15 Aug 2003, Nguyen, Tom L wrote:

> Thank you for testing it through different configurations!
> That is what we thought initially by renaming irq to something like offset or
> index to avoid some duplicate functions. However, I think if keeping them like
> above perhaps may raise a confusion again of why not name vector since the
> function vector_to_irq(...) converts a vector to irq. Please provide us final
> thoughts.

I think a variable rename should be fine, as long as the reader doesn't
get misled into thinking a specific variable is something which it isn't.
index sounds fine to me, the nice thing about your patch is that we don't
have to touch pci_dev->irq at all. The only other change would be what to
show to userspace e.g. driver prints pci_dev->irq and /proc/interrupts
prints vector. But that's all secondary...

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:47    [W:0.053 / U:2.592 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site