lkml.org 
[lkml]   [2003]   [Aug]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectusb Key problem on via M10000 with 2.6.0-test3
I cannot make my usb-key (Acer 32mb flash) working with 2.6.0 kernel.

I report here my experiments:
[scsi support enabled, hotplug enabled in the kernel and all
possible usb-stuff as module with verbose debug where possible]

lspci -v
shows 3 uhci and 1 ehci controllers every one with 2 ports.

First try:
modprobe ehci-hcd
modprobe usb-storage

dmesg reports a good measure of nice things as usb2 detected, 6 ports
available, mass storage enabled, ecc.

I insert my key and the system freeze completely (no keyboard input,
I've not tried telnet).
The usbkey led is green stable (it should pulse).

Second try:
modprobe uhci-hcd
modprobe usb-storage

dmesg still reports a lot of lines with no clear errors.

Then I insert my key and the led blink one time at all.
The system has no problem apart it doesn't seem aware of my key:
dmesg
lsusb
less /proc/bus/usb/devices

doesn't show anything different than before.

I reboot and...
Third try:
modprobe uhci-hcd
modprobe ehci-hcd
modprobe usb-storage

Now something works!
Finally the led shows the exact sequence (a short blinking and then
slow pulsing) and /var/log/messages (dmesg is far more verbose) reports:

...
new USB device on port 2, assigned address 2
Product: DiskOnKey
Manufacturer: M-Sys
Serial Number: <a long number>
SCSI emulation for USB Mass Storage devices
Vendor: M-Sys Model: DiskOnKey Rev:3.04
Type: Direct Access
scsi_agent: bogus sysfs DEVPATH=/devices/pci00000:00/000000 ....
kernel: SCSI device sda: 33MB
kernel: sda: Write Protect is off

The log ends here but there should be other informations.


Now there's /dev/sda (I'm using devfs) but no sda1 (or /dev/sda/x) so I cannot mount
it and /dev/scsi is void.

lsusb doesn't show anything while
less /proc/bus/usb/ show my Key Manufacturer and Serial Number.

If I remove the Key all data remain static and the same if I
reinsert it.

There's a similar problem on usb-storage ML but they pointed the
problem to somewhere else.


update!
while I'm writing this little poem I wanted to try the compact flash
reader of my camera, just in case... and it worked! (with uhci-hcd and
ehci-hcd both loaded).
So the problem is related to my Key partition (it's a fat but maybe is
corrupted) or M-Sys hardware.

Just writing this mail resolved my biggest problem!

Thanks
Uberto Barbini

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.083 / U:1.728 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site