lkml.org 
[lkml]   [2003]   [Aug]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectMtrr problem on via M10000 with 2.6.0-test3
Every time, X (4.3.99.10) reports at starting:

(WW) via(0): "Failed to setup write-combining range(0xe4000000,0x4000000)

The same error appears with vesa driver too.
I enabled mtrr in kernel and tried

less /proc/mtrr

...
reg03: base=0e40000000 (3648MB), size= 8MB: write-combining, count=1

The values seem right.
I also tried to change the ram amount for the video card (8-64) on bios and
it'll report correctly.

The problem is present at least since 2.6.0-test1, and with all X
versions.

Some other informations: I'm using gentoo and loaded via_agp and
agpgart, apart the error X runs nicely at first but after some time it
freeze all (telnet not responding).

Thanks for any hints or help.

Uberto Barbini

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.038 / U:6.184 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site