lkml.org 
[lkml]   [2003]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Subjecthalt/resume broke under acpi (2.4.21)
From
Date
At some point (can't say exactly when) my laptop started locking up with
acpi support.
When I try to halt the computer reaches the power down message and locks
(sometimes it goes the extra step to the blank screen with backlight
still on).
Reboot manages to reboot the computer, but then it shows the bios'
welcome screen turns on the HD led and locks.

Windows manages to halt and reboot properly, so I am guessing its not a
problem with the laptop. Also echo 5 > /proc/acpi/sleep turn the
computer off properly.

When changing in drivers/acpi/sleep.c under the function acpi_power_off
the sleep state from S5 to S4, halt started working again, but I don't
think that that is the solution. (This with acpi patched kernel, worked
the same for the matching function for the unpatched kernel).
apm halts the computer properly but doesn't reboot.
Any ideas as for solutions, how to debug the problem, or where I can
find some documentation in this task to know a bit more what I am
looking for?
Would this be a kernel bug or hardware bug?

I tried using a modified dsdt table and the original one but no
difference, and also a different version of the suspend/halt/shutdown
functions.

I am using linux debian unstable with the debian 2.4.21 kernel on a sony
vaio fxa-53 (athelon xp/via) laptop.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.024 / U:1.280 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site