lkml.org 
[lkml]   [2003]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectHangup on nforce2 UDMA
Hello

Could you please try if your nforce2 MCP southbridge is also possible
to be crashed the way I describe lower?

I have nforce2 motherboard Soltek SL75FRN2-L with MCP southbridge. Using
2.4.21 with AMD 74xx driver for IDE. If I leave the UDMA5 (UATA-100)
setting BIOS leaves on the IDE disk I can hangup the machine almost
deterministically with

cat /dev/hda > /dev/null

performed just after hard reset and subsequent boot. It hangs after max.
a minute or so. If it doesn't work, try hard reset and again, then
putting this script into /root/crash:

( a=0; while true; do echo $a; a=`/usr/bin/expr $a + 1`; sleep 1; done ) &
cat /dev/hda > /dev/null

then adding this into your lilo.conf:

image=/boot/vmlinuz
label=crash
append="init=/bin/bash /root/crash"
read-only

and finally lilo -D crash and reboot and hard reset. Repeat several
times if the crash doesn't occur on the first try.

keyboard lights don't work, alt-sysrq-b doesn't work, power off doesn't
work. Reset works. I tried NMI watchog but both with nmi_watchdog=1 and
nmi_watchdog=2 I get NMI 14 or 15 in /proc/interrupts and it doesn't
increment in 5 second intervals. Without nmi_watchdog I get NMI 0 in
/proc/interrupts. Enabling NMI watchdog and waiting 5 seconds after the
crash does nothing.

When UDMA is disabled in BIOS, I get lower performance of 17MB/s instead
of 40MB/s. I have also tried IGNORE word93 Validation BITS and AMD Viper
ATA-66 Override and none helped.

Cl<
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.041 / U:0.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site