lkml.org 
[lkml]   [2003]   [Aug]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: i8042 problem
    On Mon, Jul 28, 2003 at 12:07:43PM -0400, Pete Zaitcev wrote:
    > > From: Alan Cox <alan@lxorguk.ukuu.org.uk>
    > > Date: 28 Jul 2003 12:25:05 +0100
    >
    > > > > So the culprit is the failing of atkbd_probe().
    > > > > It does a ATKBD_CMD_GETID, but gets no answer, then a
    > > > > ATKBD_CMD_SETLEDS, and that command fails.
    > > >
    > > > I see the light now. Somehow I imagined that atkbd code does not call
    > > > the ->open for the port. Now it all falls into place. Everything works
    > > > with a bigger timeout.
    > >
    > > Unfortunately with this change several people still report failures
    >
    > I'm afraid it is to be expected. They have to go through the
    > motions of setting DEBUG. Unfortunately, it's not all that
    > simple. Messages scroll up and since the keyboard is dead,
    > they cannot be returned with Shift-PgUp. I used a serial console.
    > I think it's more effort most people are prepared to spend.

    An USB keyboard can be very helpful in that case. Or a remote login.

    --
    Vojtech Pavlik
    SuSE Labs, SuSE CR
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:47    [W:0.022 / U:0.112 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site