lkml.org 
[lkml]   [2003]   [Aug]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.0-test3 cannot mount root fs

Hi Norbert!

your config seems reasonable to me ...

> I tells me all the usual stuff concerning that it finds
> the controllers (VIA and HPT) and disks/cdroms, but than
> hangs with
> cannot mount rootfs "NULL" or hdb1

AFAIK, there is no such message in 2.6.0-test3 ...

if, on the other hand, the message looks like ...

-----------
VFS: Cannot open root device "hdb1" or unknown-block(0,0)
Please append a correct "root=" boot option
-----------

then this means that "hdb1" was the device given at
the kenel command line (as root=/dev/hdb1) and the
'unknown-block(0,0)' is the major/minor the kernel
recognized ...

you should pay special attention to the disc/partition
discovery done by the IDE subsystem ...

-----------
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 128KiB
hda: 65537 sectors (33 MB) w/256KiB Cache, CHS=65/16/63
hda: hda1
hdb: 131074 sectors (67 MB) w/256KiB Cache, CHS=130/16/63
hdb: hdb1 hdb2 hdb3
...
-----------

maybe you could attach a serial console (line)
and capture the boot process, and report it ...

HTH,
Herbert

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.103 / U:0.892 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site