lkml.org 
[lkml]   [2003]   [Aug]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Linux [2.6.0-test3/mm1] aic7xxx problems.
From
Date
On Mon, 2003-08-11 at 13:22, Justin T. Gibbs wrote:

> > On a side note, the same aic7xxx drivers version 6.2.8 and 6.2.36 works
> > with 2.4.21 and 2.4.22-rc1/rc2 series of kernel with above hardware.
>
> I don't think that any of the changes between 6.2.35 and 6.2.36 will
> make a difference for you, but you could try upgrading. The source
> files are here:
>
> http://people.FreeBSD.org/~gibbs/linux/SRC/
>

Tried those already on both 2.4.21/22 and 2.6.0-test1,2,3.
While the 2.4 driver compiles and works fine the 2.5 sources does not
play nice with 2.6.0-test* kernel.I had to change the includes to blkdev
in the source and then there was few compile warnings.I can try to
provide the exact ones, unless there's a driver that applies to
2.6-test* cleanly.Once i had it compiled the kernel would just panic.

> The console output you've provided makes me think that interrupts are
> not working correctly in your system.
>

Is this due to my mainboard (nforce2),cpu,ACPI,devfs,sysfs...or all
these together?

I tried swapping the SCSI controller card in various PCI slots,used new
and original working cables,changed the BIOS IRQ's...etc

I start running of ideas here, is there other options to fully debug the
problem? What else can i try? I would appreciate any pointers.

I would like to get things working with 2.6.0 kernels...right now only
aic7xxx_old is somehow working but that's not the solution to the
problem.

> --
> Justin
>
>

Thank you for your time.

Paul


[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.074 / U:0.868 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site