lkml.org 
[lkml]   [2003]   [Jul]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [REPOST] "apm: suspend: Unable to enter requested state" after2.5.31 (incl. 2.6.0testX)
From
Stephen Rothwell said:
> If you get no OOPS from running the above, then you could try the second
> patch below. If your machine still behaves the same way, then you have
> completely ruled out that change to the apm code ... so we need to look
> elsewhere.

I guess it wasn't using that descriptor. The machine behaved the same way
as before when I tested each patch ("unable to enter requested state", and
system comes back to normal).

While experimenting, I noticed something else: in the cases where a system
suspend failed ('apm -s', closing the lid, or activating IBM's hibernate
mode), a 'system standby' request worked. Trying to transition from
standby to suspend does not work, however-- the laptop wakes up, and
eventually prints the same error message as for a normal suspend.

thanks for the patch,

--
Charles Lepple <clepple@ghz.cc>
http://www.ghz.cc/charles/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.120 / U:2.300 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site