lkml.org 
[lkml]   [2003]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: 2.6.0-test2-mm1: Can't mount root
From
Date
-test1-mm2. Hadn't tried any -bk? in between.

Won't have time to do much tonight or tomorrow before evening, but I'll
test what I can.

On Mon, 2003-07-28 at 21:36, Andrew Morton wrote:
> Shawn <core@enodev.com> wrote:
> >
> > OK, mucho more info (no wonder root=/dev/hde5 no worky):
> > VP_IDE: (ide_setup_pci_device:) Could not enable device
> >
> > Found out my on board via pci ide was not getting initialized under
> > -test2-mm1, so I went looking for driver/ide/pci/via82cxxx in the diffs.
> > I found this in the -test2 diff:
> > - (((u >> i) & 7) < 8))) {
> > + (((u >> i) & 7) < 6))) {
> > ...and reversing it did not change anything.
> >
> > The only other diff I could think might matter to
> > drivers/ide/setup-pci.c
> > -static unsigned long __init ide_get_or_set_dma_base (ide_hwif_t *hwif)
> > +static unsigned long ide_get_or_set_dma_base (ide_hwif_t *hwif)
> > ...which does not look like it should kill my via ide...
> >
>
> OK, looks like breakage at the PCI level: pci_enable_device_bars() is
> failing; something below pcibios_enable_device().
>
> What was the most recent kernel which works?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.052 / U:0.136 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site