lkml.org 
[lkml]   [2003]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: NFS server broken in 2.4.22-pre6?
I don't know if this is related or not, but I noticed that on old 
redhat-6.2 (glibc-2.1.3) systems, portmap dies instantly under 2.4.21+
kernels. Older 2.4.18 kernels worked fine. It exits with -EBADF. I can get
a complete strace if that's interesting. I tested the portmap binary from
redhat-7.2 (which works under redhat-7.2) in the 6.2 environment, and it
had the same problem, so it's not portmap itself.

-matt c

On Sat, 26 Jul 2003, Hugo Mills wrote:

> On Fri, Jul 25, 2003 at 10:05:33AM -0300, Marcelo Tosatti wrote:
> >
> >
> > On Thu, 24 Jul 2003, Meelis Roos wrote:
> >
> > > NFS serving seems to be broken in 2.4.22-pre6. I had 2 computers running
> > > 2.4.22-pre6 (x86, debian unstable current). Tried to acces them via NFS
> > > (using am-utils actually) from a 3rd computer, IO error. Tried to
> > > mount directly, mount: RPC: timed out. Rebooted one computer to 2.4.18
> > > and NFS started to work.
> > >
> > > No more details currently but I can test more thoroughly tomorrow.
> >
> > Meelis,
> >
> > Please report more details.
>
> I'm also having trouble with NFS, with a 2.4.22-pre6-ac1 server.
>
> I'm booting a diskless workstation (with a 2.4.21-ac1 client), and
> it will boot and mount the root filesystem. When I try to mount any
> other filesystems, the client reports
>
> mount: can't get address for vlad
>
> and loses the main NFS mount: attempts to access any file on the root
> filesystem gives stale NFS file handle errors. The failure to mount
> also breaks the server -- I can no longer boot the diskless client.
> Restarting the NFS server allows me to boot the client once again.
>
> Like Meelis, I'm also using Debian unstable, and I've tried with
> both the 1.0.3-1 and 1.0.5 versions of the nfs-tools on both machines.
> Both versions give the same error that I reported above.
>
> Hugo.
>
>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.092 / U:1.976 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site