lkml.org 
[lkml]   [2003]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjecttimeout (110) with bluez usb uhci 2.4.21
The same problem here as the one raported about a week ago by Florian
Lohoff. I have two USB bluetooth dongles. One of them (ambicom
bt2000) does not like being hotplugged in it gives that timeout message
after saying it was an error in interrupt.The other (blue-gene bt320)
can be connected/disconncted and it works fine.
The same problem shows with 2.4.22-pre7
If the usb-uhci module is reloaded while the dongle is in it finds it.
The problem as shown by debug messages in uhci seems to be error in the
interrupt handler for uhci. The status register is 2 which is io/error I
think and it says the frame was corrupted.
So I changed the handler to return when that's the status and only go on
if status is 1 which I think is normal usb interrupt transfer not an
error condition. This way probably the usb stack retries again and the
dongle is found after a few seconds and can be plugged in and out.
I have seen in other threads that somebody made usb_get_address retry on
error to achieve the same effect...
can some workaround by somebody who knows what's happening be put in the
kernel because google shows that quite a few people are bitten by this
110 error message with uhci/ohci and various usb devices not only BT.

thanks
Jani
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.035 / U:1.544 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site