lkml.org 
[lkml]   [2003]   [Jul]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: matroxfb and 2.6.0-test2
On Tue, 29 Jul 2003, Petr Vandrovec wrote:

> On Mon, Jul 28, 2003 at 08:34:40PM -0300, Frédéric L. W. Meunier wrote:
> >
> > My init script contains
> >
> > if lspci | grep -q 'MGA G400'; then
> > modprobe matroxfb_base
> > fi
> >
> > and /etc/modprobe.conf options matroxfb_base vesa=440
> >
> > After it the screen became corrupted with a dump of my last
> > shutdown. All commands still worked. I don't use fbset at all.
> > The logs don't have anything about matroxfb.
>
> Try building matroxfb into the kernel. I believe that current VT system
> does not take over console anymore if fbdev is loaded after fbcon, but
> I never tested it myself.

Thanks. It worked (and I don't see any screen corruption).

Maybe I'm missing something, but is there anything wrong with
video=matroxfb:vesa:0x1B5 ? I got

Kernel command line: BOOT_IMAGE=3 root=307 acpi=off noapic video=matroxfb:vesa:0x1B5
Console: colour VGA+ 80x25
matroxfb: Matrox G400 (AGP) detected
matroxfb: MTRR's turned on
matroxfb: 800x600x24bpp (virtual: 800x65536)
matroxfb: framebuffer at 0xD8000000, mapped to 0xe0805000, size 33554432
fb0: MATROX frame buffer device
fb0: initializing hardware
matroxfb: cannot set xres to 800, rounded up to 832
Console: switching to colour frame buffer device 100x37
/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 p8 p9 p10 >
Console: switching to colour frame buffer device 100x37
matroxfb_crtc2: secondary head of fb0 was registered as fb1

and the monitor was black on part (a few cm) of the left side,
although everything was on the screen.

It worked fine with what I'm used to, 1024x768x32bpp;

Kernel command line: BOOT_IMAGE=3 root=307 acpi=off noapic video=matroxfb:vesa:0x1B8
Console: colour VGA+ 80x25
matroxfb: Matrox G400 (AGP) detected
matroxfb: MTRR's turned on
matroxfb: 1024x768x24bpp (virtual: 1024x65536)
matroxfb: framebuffer at 0xD8000000, mapped to 0xe0805000, size 33554432
fb0: MATROX frame buffer device
fb0: initializing hardware
Console: switching to colour frame buffer device 128x48
/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 p8 p9 p10 >
Console: switching to colour frame buffer device 128x48
matroxfb_crtc2: secondary head of fb0 was registered as fb1

and with the default:

Kernel command line: BOOT_IMAGE=3 root=307 acpi=off noapic
Console: colour VGA+ 80x25
matroxfb: Matrox G400 (AGP) detected
matroxfb: MTRR's turned on
matroxfb: 640x480x8bpp (virtual: 640x65536)
matroxfb: framebuffer at 0xD8000000, mapped to 0xe0805000, size 33554432
fb0: MATROX frame buffer device
fb0: initializing hardware
Console: switching to colour frame buffer device 80x30
/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 p8 p9 p10 >
Console: switching to colour frame buffer device 80x30
matroxfb_crtc2: secondary head of fb0 was registered as fb1

BTW, I'm pretty syre I only got the following warning compiling
as a module (GCC 2.95.4):

CC [M] drivers/video/matrox/matroxfb_base.o
drivers/video/matrox/matroxfb_base.c:1230: warning: `inverse' defined but not used
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.068 / U:0.092 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site