lkml.org 
[lkml]   [2003]   [Jul]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.6.0-test2 - VFS: Cannot open root device "NULL" or sda1
Date
In <3F24A548.2040202@rogers.com> gaxt <gaxt@rogers.com> writes:

>Yifang Dai wrote:
>> On Sun, Jul 27, 2003 at 08:42:13PM +0000, Henrik Storner wrote:
>>
>>>So I know 2.6.0-test1 works for me. But 2.6.0-test2 with the same
>>>configuration (just a "make oldconfig" in between) stops during boot
>>>with:
>>>
>>>VFS: Cannot open root device "NULL" or sda1
>>
>> I've got the same error, except my root device is /dev/hda3. It also
>> worked in 2.6.0-test1 :)

>I believe you need to change in your grub.conf file the root=/dev/hda3
>to a root=### ie root=0307

Doesn't seem to do much good here. I've tried:

root=/dev/sda1
root=0801
root=801
root=2049 (0801 hex = 2049 decimal)
root=08:01
root=/dev/sda/1

but none of them gets the kernel to mount the root fs (yes, I do
have the SCSI driver and my reiserfs filesystem compiled in).

Anyone who added patches to -test2 who have a clue about what
is going on ?


Henrik
--
Henrik Storner <henrik@hswn.dk>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.086 / U:0.556 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site