lkml.org 
[lkml]   [2003]   [Jul]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.0-test2 - VFS: Cannot open root device "NULL" or sda1
Yifang Dai wrote:
> On Sun, Jul 27, 2003 at 08:42:13PM +0000, Henrik Storner wrote:
>
>>So I know 2.6.0-test1 works for me. But 2.6.0-test2 with the same
>>configuration (just a "make oldconfig" in between) stops during boot
>>with:
>>
>>VFS: Cannot open root device "NULL" or sda1
>>Please append a correct "root=" boot option
>>Kernel panic: Unable to mount root fs on sda1
>>
>
>
> I've got the same error, except my root device is /dev/hda3. It also
> worked in 2.6.0-test1 :)
>

I believe you need to change in your grub.conf file the root=/dev/hda3
to a root=### ie root=0307

The number is composed of 3 pieces

(a) major device number ie. 3 above (leading zero is ignored)
(b) minor device number ie. 0 above
(c) partition on device ie. 7 above

I use hdb. hda and hdb are both major device number 3

hda is minor device number 0
hdb is minor device number 64
BUT minor device number is in base 16
so in base 16, hda is 0 (0x16=0) and hdb is 4 (4x16=64)

THUS

my root=/dev/hdb4 becomes root=344 (ie. maj device 3, minor device 64
(4x16) and partition #4.

Examples:

hda1 = 301
hda3 = 303
hdb1 = 341
hdb4 = 344 etc.

Pardon if this is obvious. To determine linux device numbers, google.
there's a list out there. I found a list below:

http://www.lanana.org/docs/device-list/devices.txt

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:47    [W:0.069 / U:4.140 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site