[lkml]   [2003]   [Jun]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    Subject[RFC] pci_name()

    I'd kind of like to get rid of pci_dev->slot_name. It's redundant with
    pci_dev->dev.bus_id, but that's one hell of a search and replace job.
    So let me propose pci_name(pci_dev) as a replacement. That has the
    benefit of being shorter than either of the others and lets us do fun
    & interesting things later (maybe construct it on the fly for systems
    that want to save 20 bytes per device?). We can transition it in over
    2.5/2.6/2.7 and kill pci_dev->slot_name for 2.8.

    Oh, and without killing slot_name immediately, we can save 4 bytes on
    32-bit platforms by turning it into a pointer to the dev.bus_id.


    "It's not Hollywood. War is real, war is primarily not about defeat or
    victory, it is about death. I've seen thousands and thousands of dead bodies.
    Do you think I want to have an academic debate on this subject?" -- Robert Fisk
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:36    [W:0.017 / U:14.252 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site