lkml.org 
[lkml]   [2003]   [Jun]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: 2.4.21 doesn't boot: /bin/insmod.old: file not found
    From
    Date
    Hi Keith,

    On Mon, 2003-06-23 at 11:26, Keith Owens wrote:
    > On 22 Jun 2003 19:07:58 +0200,
    > Ronald Bultje <rbultje@ronald.bitfreak.net> wrote:
    > >After that, I installed the newest modutils (2.4.25) and
    > >module-init-tools (tried both 0.9.12 and 0.9.13-pre), created symlinks
    > >in /bin for all *mod* tools pointing to /sbin/$file, and I still cannot
    > >get 2.4.21 to get further than this error (obviously, /bin/insmod.old
    > >_is there_, I'm not that stupid. ;) ). I use initrd with filesystem
    > >modules and some more in it, so obviously it fails with a panic saying
    > >that /sbin/init wasn't found (no single HD mounted).
    >
    > Did you copy /bin/insmod.old to the initrd that you are booting from?
    > Is /bin/insmod.old a static binary?

    /bin/insmod.old is a symlink to the dynamically linked binary in
    /sbin/insmod.old. The static one is in /{s,}bin/insmod.static.old.
    Should I swap them around?
    Also, I did recreate the initrd image (that should be enough, right?),
    but still get the same error on bootup.

    Thanks,

    Ronald

    --
    Ronald Bultje <rbultje@ronald.bitfreak.net>

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:36    [W:0.020 / U:61.356 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site