lkml.org 
[lkml]   [2003]   [Jun]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [FIX, please test] Re: 2.5.70-bk16 - nfs interferes with s4bios suspend
Hi!

> > > I didn't have any actual nfs mounts at the time but I tried it
> > > with an otherwise similar system. It went through, got to freeing
> > > memory, showed me a bunch of fullstops being drawn and then went
> > > into an endless BUG loop. All I could pick out (after many a moment
> > > of staring) was 'schedule in atmoic'.
> > >
> > > I'll do a proper test with a console cable present in a few days. I
> > > can't atm cos I'm not on the same network and don't have a 2nd
> > > computer to hook up the null-modem cable to.
>
> Was able to capture the output for this case (it's long). The result
> without preempt is below this one.

> I hit the power button here and shut the box down.
>
> > Turn it off. You don't want to debug preempt and nfs at the same time.
>
> And this is with preempt off:
>
> Stopping tasks: XFree86 entered refrigerator
> =pdflush entered refrigerator
...
> =init entered refrigerator
> =procmail entered refrigerator
> =|
> Freeing memory: .........................|
> Syncing disks before copy
> Suspending devices
> Suspending device c052c48c
> Suspending devices
> Suspending device c052c48c
> suspending: hda ------------[ cut here ]------------
> kernel BUG at drivers/ide/ide-disk.c:1110!

Okay, you hit some ide problems, but freezing NFS worked okay. Did you
have active NFS mounts at this point?
Pavel
--
When do you have a heart between your knees?
[Johanka's followup: and *two* hearts?]
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:36    [W:0.057 / U:2.496 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site