lkml.org 
[lkml]   [2003]   [Jun]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: init does not run on 405GP system
From
Date

> On Wed, Jun 11, 2003 at 09:53:04AM +0300, Denis Vlasenko wrote:
> > I once tried to run 686 based libc on a 486, init was rained upon
> > by SIGILLs 'coz it had 586+ instructions. No output on the screen
> > whatsoever.
>
>
> I've tried it with the DENX busybox rootimage which is definitely
> tested
> extensively on PPC4xx, but it does not work.
>
>
> Robert
>
Hi,

You may have wrong compilation options.
Please send me your test program and I'll test it on a PPC403 board.
>From my tests, it seems that gcc 3.xx specs are quite buggy for those
embedded processors and need to be patched to produce correct code.

Regards.

--
Jocelyn Mayer <jma@netgem.com>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:36    [W:0.017 / U:1.908 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site