lkml.org 
[lkml]   [2003]   [Jun]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] And yet more PCI fixes for 2.5.70
From
Date
On Mer, 2003-06-11 at 01:11, Greg KH wrote:
> /* user supplied value */
> system_bus_speed = idebus_parameter;
> - } else if (pci_present()) {
> + } else if (pci_find_device(PCI_ANY_ID, PCI_ANY_ID, NULL) != NULL) {

That is just gross. pci_present() is far more readable even if you make
it an inline in pci.h that is pci_find_device(PCI_ANY_ID, PCI_ANY_ID,
NULL)

Alan

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:36    [W:0.196 / U:1.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site