Messages in this thread |  | | Date | Fri, 9 May 2003 16:05:42 -0700 | From | Greg KH <> | Subject | Re: [linux-usb-devel] Re: [Bluetooth] HCI USB driver update. Support for SCO over HCI USB. |
| |
On Fri, May 09, 2003 at 03:35:36PM -0700, Max Krasnyansky wrote: > Ok. Sounds like it should be > uint32_t hcd_cb[16]; // 64 bytes for internal use by HCD > uint32_t drv_cb[2]; // 8 bytes for internal use by USB driver
s/uint32_t/u32/ please. And if this is going to be used for pointers, why not just say they are pointers? Otherwise people are going to have to be careful with 32 vs. 64 bit kernels to not overrun their space.
struct sk_buff uses a char, any reason not to use that here too? Has being a char made things more difficult for that structure over time?
thanks,
greg k-h - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
|  |