[lkml]   [2003]   [May]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectCopying disks using cat makes 2.4.20 very unresponsive

If I copy disk or partition eg. /dev/hda1 to /dev/hdc1:
cat /dev/hda1 > /dev/hdc1 the system becomes __highly__ unresponsive
The same is for:
cat /dev/zero > /dev/hda1
Processor is about 90 % idle
'cat' takes about 3-5 % CPU.
Load average is about 5
Working with X is impossible (about 1 second freeze every 1-2 seconds).
renice -19 for X makes no difference.

What is really strange, if I use 'dd' eg.:
dd if=/dev/hda1 of=/dev/hdc1 bs=1024 count=1000000
there are NO freezes at all.
The system works smoothly. Load is about 1.2.
dd takes for some time 30% CPU and then until finishes about 0.2 % CPU.
I have tried bs=512,1024,2048,4096,8192,16384.
It works smoothly with all above values.
Also cat /dev/hda1 > /dev/null doesn't hurt.

My system description:
I have linux 2.4.20.
System is based on RedHat 8.0. Tried with RH 9.0 also.
Motherboard ASUS A7V266A (via KT266A chipset)
2 IBM SCSI disks connected to Adaptec 2940U2W
CD-RW, DVD-RAM connected to the same Adaptec card
2 IBM IDE disks connected to motherboard controller.
IDE disks use DMA, and are set to UDMA-100

System is installed on SCSI disks.

Please CC me.


Olaf Fraczyk

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:35    [W:0.488 / U:0.308 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site