lkml.org 
[lkml]   [2003]   [Mar]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectIDE DMA/VIA woes on SuSE 2.4.19-167
Hi,

I have some issues here:

Plextor PX-W4824TA 1.03 as hdc (no hdd)
VIA KT133

00:07.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev 10) (prog-if 8a [Master SecP PriP])
Flags: bus master, medium devsel, latency 32
I/O ports at ffa0 [size=16]
Capabilities: [c0] Power Management version 2

When I try to enable DMA (hdparm -d1 or hdparm -d1 -X66), hdparm -tT
chokes, SuSE k_athlon-2.4.19-167. FreeBSD-5 (with atapicam) is fine and
uses UDMA33.

SuSE's kernel seems to be fine on a different hardware (VIA KT333 +
Toshiba SD-M1612).

I've tried 2.4.21-pre5 which crashes on boot, I haven't yet been able to
go fishing for the Ooops and decode it (I have serial console here, so
it's just a matter of finding the time to do that).

ide-scsi makes no difference (not that I had expected that).

Which kernel version should I try next before thinking about this for
longer?

--
Matthias Andree
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.042 / U:0.060 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site