lkml.org 
[lkml]   [2003]   [Mar]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [ACPI] Re: S4bios support for 2.5.63
[removed ACPI mailing list from cc:]

On Mon, 03 Mar 2003 15:07:54 +0100, Troels Haugboelle wrote:
> just to add my experience. Maybe it helps. I haven't been able to get
> swsusp working on any 2.4.x kernel until i did an
> hdparm -u1 /dev/hda
> now the strange thing: I tried to turn on the frame buffer device and
> it started chrashing again until i did
> hdparm -u0 /dev/hda
> Before I tried using suspend in 2.5.x with varying success. Now
> everything runs like a charm. Without unmask irq's first the kernel
> dumped
> with either a kernel BUG statement or a fault in ide-disk.c

Not sure I follow all of your story but I can confirm that hdparm -u1
successfully gets me to the kernel panic due to highmem support still
lacking -- i.e. way beyond the BUG_ON() I've been hitting. So it looks
like you found a good work-around.

FWIW I'm using reiserfs, too. Two harddisks, ALi chipset.

Roger
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.126 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site