lkml.org 
[lkml]   [2003]   [Mar]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectProblems with PCI IRQ routing
	Hello,

I've just acquired a Conceptronics C11iDT Wireless card, it's
the PCI version, but in fact it's just a PCMCIA card plus a PCI-PCMCIA
adaptor. The problem is that I'm not able to make the adaptor works,
when I load the yenta_socket module (from linux kernel 2.4.20) I get:

PCI: No IRQ known for interrupt pin A of device 00:0d.0. Probably buggy MP table.
Yenta IRQ list 0000, PCI irq0
Socket status: 30000810

and if I disable the APIC (noapic option) I get

PCI: Enabling device 00:09.0 (0000 -> 0002)
PCI: No IRQ known for interrupt pin A of device 00:09.0. Please try using pci=biosirq.
Yenta IRQ list 0000, PCI irq0
Socket status: 30000810

if I try with pci=biosirq I get the same problem.

When booting linux I get:

PCI: PCI BIOS revision 2.10 entry at 0xfd7e0, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
BIOS failed to enable PCI standards compliance, fixing this error.
I/O APIC: AMD Errata #22 may be present. In the event of instability try
: booting with the "noapic" option.

but it never caused any problem until now...

I've tried in other PCI slots with the same result (only the device
number changed). I have linux kernel 2.4.20 and pcmcia-cs-3.2.4.
I'm running in a Tyan S2460 with BIOS 1.05. I've tried setting some IRQs
in the bios to be reserved and it doesn't get better. Also tried to
disable the IRQ Table in bios (option of the S2460 bios) with the same
result.

I've attached lspci -v output, and /proc/interrupts, if you need
any more info I'll send as much as I could get.

Best regards,

- german

PS: Please CC'd to me as I'm not subscribed to the kernel list, thanks.

--
Send email with "SEND GPG KEY" as subject to receive my GnuPG public key.
[unhandled content-type:application/x-gunzip][unhandled content-type:application/x-gunzip]
\
 
 \ /
  Last update: 2005-03-22 13:34    [W:0.035 / U:17.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site