lkml.org 
[lkml]   [2003]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: 2.5.64-mm6
From
Date
Andrew Morton <akpm@digeo.com> writes:

> Alexander Hoogerhuis <alexh@ihatent.com> wrote:
> >
> > I've used tried the -mm-kernels since they've actually made
> > 2.5-kernels usable on my laptop lately (Compaq Evo800c), but
> > 2.5.64-mm2 and onwards doesnt work with X anymore. I run 4.3.0-r1 from
> > the Gentoo unstable "branch".
> >
> > with -mm1 I X coming up just nicely, and now the screen just goes
> > black after trying to start X, and it seems related to DRM.
>
> I have a radeon card here. Just tried it. The X server starts up OK but as
> soon as I run tuxracer, some ioctl down in the radeon driver keeps on timing
> out waiting for the FIFO, spins for ten milliseconds in-kernel and the X
> server immediately calls the ioctl again. The whole thing is bust. I went
> all the way back to 2.5.39, where it is still bust. 2.4.21-pre5 is OK
> though.
>
> So it looks like my breakage is different from yours.
>
> Could you please try just 2.5.64 plus
> http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.5/2.5.64/2.5.64-mm6/broken-out/linus.patch
>
> That will tell us if it is a -mm bug or a -linus bug.
>

Vanilla 2.5.64 is b0rken, too. Tried it, and went back and tries -mm6
with and without ACPI as well, no difference. So instead of trudging
through that liste of change sets, I'll back out one and one patch
from -mm1 back to plain .64 to see where the thing goes belly
up. Seems reasonable?

mvh,
A
--
Alexander Hoogerhuis | alexh@ihatent.com
CCNP - CCDP - MCNE - CCSE | +47 908 21 485
"You have zero privacy anyway. Get over it." --Scott McNealy
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.065 / U:3.436 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site