lkml.org 
[lkml]   [2003]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectNewbie with SiS 900 NIC driver, SuSE 8.1 and Fujitsu-Siemens Celvin EasyPC.
Please personally CC the answers/comments posted to the list in response 
to my posting, as I am not a list member. I have tried getting the SiS
900 driver to run on SuSE 7.3, (and now) 8.1, Mandrake 8, 8.1, 9, Debian
3 rev.1 as well as running the latest Knoppix, none of which has been
successful. Being a newbie and having only an interest in this one issue
that I have never been able to resolve, I really don't belong on the
list either. However, I believe that there is either a bug in the driver
or my configuration is not supported. Either way, I would like to get
the issue cleared up.

Anyway, to the issue at hand. There is a Fujitsu-Siemens Celvin EasyPC
connected to my home WAN/LAN that I have been trying to get to work with
the SiS 900 driver. The box has a SiS 900 NIC built into a Biostar
motherboard and uses an Award BIOS. The WAN/LAN consists of 4 computers
connected to a LinkSys router and a 3 Com cable modem. All other
computers are able to connect to the Internet through auto DHCP,
including one that is a dual boot Win2k Pro and SuSE 8.1 box. The Celvin
is neither able to connect through auto DHCP or with a static IP
address. I have checked the physical connection using a USB to Ethernet
adapter and Knoppix, so I know the problem doesn't lie there. The SiS
900 NIC itself, works fine under Win 98 SE. This seems to me to rule out
a number of things. Using SuSE 8.1, I have tried:

su
hwinfo --network_ctrl

Included in the info that came back was the following:

Revision: 0 x 01
Driver status: active
Config status: cfg=yes avail=yes need=no

I have found a couple of lines in /var/log/boot.msg that are of
relevance as well. With auto DHCP, the message says "DHCP no IP address
yet... backgrounding". When set to static IP, the boot.msg lists eth0
with the correct IP address and subnet mask and that is it.

I don't want to confuse the issue as I am using SuSE 8.1 at this time
however, I think it is also worth noting that with Debian 3 rev. 1
installed, the output of # /sbin/ifconfig eth0 192.168.1.111 was:

eth0 Media Link Off.

The result of "$ ping 216.239.57.100" was:

Network is unreachable

I understand if you don't want to help me with my own personal
configuration problems, but it would be nice to know if there is a bug
in the driver or if my configuration is unsupported.

Cheers,

Brian Durant




-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.046 / U:3.200 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site